Genvid Forum

Genvid Technologies

Youtube streaming

I am not able to load my local streaming to my youtube streaming.

Hi,

Welcome to our Forum!

In order to better understand what issues you are encountering with streaming to YouTube, allow me to outline some of the essential steps required to make this work.

  1. First, configuring your YouTube account to allow for streaming:
    https://www.genvidtech.com/doc/SDK-1.23.0/streamingservices/youtube.html
    Be advised that the account streaming configuration can take 24-48h to be approved by YouTube before you are able to stream to it. This is sadly out of our control and why we offer the standalone option.
  2. Next, you add the channel ID and secret key to the youtube.sample.hcl file located within the Genvid installation folder in …\samples\streaming_services .
    https://www.genvidtech.com/doc/SDK-1.23.0/streamingservices/youtube.html#settings
  3. Finally, loading the .hcl to your cluster by running the command genvid-sdk load-config youtube.sample.hcl. This will update your cluster with all the information required for streaming to the YouTube channel.
    Note: You need to be sure to stop all in your cluster before loading the configurations.

If you are still experiencing issues after following the above steps, please let me know and I will help you with trying to resolve the issue.

Thanks!


The Genvid Team

Upon further investigation into this matter, YouTube has implemented a Partner Program which is now required to be a member of in order to stream to their platform.

For more information regarding this program, see their help page:
https://support.google.com/youtube/answer/72851?hl=en

Thank You, My problem has been solved.