Genvid Forum

UE4 plugin crash in REST API


#1

Hi,

I’m experiencing a crash inside the Genvid plugin on launching our game (based on unreal engine 4.18). We are using the latest Genvid SDK 1.12.

It would appear to be some kind of corruption of the “OnRequestSuccessedCallback” delegate within Genvid’s REST API code.

Callstack pasted below:

Suggestions welcome.


#2

Hi Adrian,

The Genvid SDK officially supports UE 4.15.3, and is compatible up to version 4.17.2. However, the behavior you are describing is unusual and we will investigate this further (it shouldn’t crash on launch even with 4.18).

Please expect a followup soon with additional information.

Thanks!
Sophie


#3

Hi Sophie

If it’s of any relevance, this behaviour only seems to occur when you use the launch button from the editor - if your launch the game in editor mode (i.e. with the -game command line option to bypass the editor UI), the crash doesn’t seem to occur.

Is there any information on what may not be compatible in Unreal versions above 4.17.2 ?

Thanks,

Adrian


#4

Hi Adrian,

Noted! This will definitely help with tracking down the issue.

Thanks!!
Sophie


#5

Hi Adrian,

Our team has created a patch for 1.12.0 to address this issue. The fix will be available in the 1.13.0 release (scheduled for next week) which will be compatible for versions 4.15.3 to 4.19.1.

When the 1.12.0 patch is ready, I will send you a private message with a link to the .zip for download.

Cheers.
Sophie