Genvid Forum

Setting silent to false kills video too


#1

Hi,

I followed the instructions in an earlier post to set silent to false (in the cluster settings). However, when I do this the video is no longer streaming to YouTube either.

My game log shows an error:

avcore\audiocore\client\audioclient\audioclientcore.cpp(1477)\AUDIOSES.DLL!00007FF9D3C6CFB5: (caller: 00007FF9D3C5AB4A) ReturnHr(1) tid(3ea8) 887C0030 [2018.06.26-10.52.57:772][ 0]LogGenvid: Error: SetParameterInt(Audio.Source.WASAPI) failed: AllocationFailed (6)

… even though the GENVID_AUDIO_DEVICE environment variable is set to Speakers (this is on my local cluster).

However, even if I don’t set WASAPI on for the audio stream (i.e. leave it as None for the AudioMode), which removes the above error from the log as there’s no other audio capture, streaming out of the video still does not work whilst Silent=false.

Thanks,

Adrian


#2

Hi Adrian!

Our team will look into this and we’ll provide you an answer as soon as possible!

Best,

Pierre


#3

Hi Adrian,

Could you run : genvid-bugreport broadcast right after the problem showed up and send the zip file that will be generated ? This file will contain all the logs and I will take a look at them.

Thanks,

PhM


#4

Hi Adrian!

I just wanted to do a quick follow up on this issue. Do you still need help on this topic?

Best,

Pierre


#5

Yes please - I have PM’ed you with the log files.


#6

Hi Adrian,

The problem lies here :

I0626 15:27:14.214624 22096 AudioGrabber.cpp:299] No GENVID_AUDIO_DEVICE variable found.
I0626 15:27:14.214624 22096 AudioGrabber.cpp:310] Using the default audio endpoint.

E0626 15:27:14.221595 22096 AudioGrabber.cpp:345] Failed to Initialize audio client: -2004287480
E0626 15:27:14.221595 22096 AsyncConnections.cpp:1094] SetParameter() - Failed to initialize WASAPI for stream ‘Audio’: AllocationFailed (6).

Error -2004287480 is 0x88890008 which is AUDCLNT_E_UNSUPPORTED_FORMAT.

Looks like something is not right with using the default audio endpoint. I suggest that you define the GENVID_AUDIO_DEVICE environment variable to make sure the audio endpoint used is the one you intend to use and see if this time it is properly initialized.

Let me know how it went,

Edit : You mentioned that GENVID_AUDIO_DEVICE was set to “Speakers”, you might want to check this as well as the logs state that GENVID_AUDIO_DEVICE was not found, typo may be ?

PhM


#7

OK, fixed the environment variable (was an issue with environment variable inheritance I think … probably had to be set BEFORE bastion was installed and hence before it starts up nomad).

However this doesn’t fix the issue, the stderr is now showing this:

I0629 10:49:06.667282 17948 AsyncConnections.cpp:729] Stream Audio created.
E0629 10:49:06.667282 12312 StatsdClient.cpp:442] genvid.sdk.: Empty service name in consul info!
I0629 10:49:06.667282 17948 AudioGrabber.cpp:191] GENVID_AUDIO_DEVICE variable is : Speakers
I0629 10:49:06.671270 17948 AudioGrabber.cpp:211] 2 available devices are : 
I0629 10:49:06.672268 17948 AudioGrabber.cpp:235] Speakers
I0629 10:49:06.672268 17948 AudioGrabber.cpp:235] 227E4LH-C
I0629 10:49:06.673265 17948 AudioGrabber.cpp:321] Using : Speakers.
E0629 10:49:06.677284 17948 AudioGrabber.cpp:345] Failed to Initialize audio client: -2004287480
E0629 10:49:06.677284 17948 AsyncConnections.cpp:1094] SetParameter() - Failed to initialize WASAPI for stream 'Audio': AllocationFailed (6).

As you mentioned on the error code, this suggests it is an issue with the audio format I guess. I’m setting it to F32LE, is it possible that is unsupported?

Adrian


#8

(I did try with setting the AudioStream’s format to S16LE also, same error …)

Adrian


#9

Hi Adrian,

The team is looking at this we’ll get back to you shortly.

Best,

Pierre


#10

Hi Adrian,

Looking into it. It seems that this is going to be tricky as MSDN says that what we are doing should work, but in your case it does not seem to.

One thing you could try is to set GENVID_AUDIO_DEVICE to 227E4LH-C to see if this makes a difference. Let me know how this went, it might bring a hint.

PhM


#11

Setting the audio device to 227E4LH-C does stop the initialise error in the log, however Youtube streaming still does not work when the silent setting is set to false. Not sure if the default value warnings for stamp_scale and quality (see log below) matter?

I0702 12:03:38.028246 21848 AsyncConnections.cpp:729] Stream Audio created.
I0702 12:03:38.028246 21848 AudioGrabber.cpp:191] GENVID_AUDIO_DEVICE variable is : 227E4LH-C
I0702 12:03:38.032265 21848 AudioGrabber.cpp:211] 2 available devices are :
I0702 12:03:38.032265 21848 AudioGrabber.cpp:235] Speakers
I0702 12:03:38.033231 21848 AudioGrabber.cpp:235] 227E4LH-C
I0702 12:03:38.038251 21848 AudioGrabber.cpp:321] Using : 227E4LH-C.
I0702 12:03:38.050186 31304 AsyncConnections.cpp:226] KVStore::Get() failed to get genvid/encode/input/stamp_scale with error : Status Code: 404; Default value will be used.
I0702 12:03:38.050186 31304 AsyncConnections.cpp:226] KVStore::Get() failed to get genvid/encode/input/quality with error : Status Code: 404; Default value will be used.
I0702 12:03:38.054175 21848 AudioGrabber.cpp:393] Audio Client Setup: {0.0.0.00000000}.{f2c43625-c74c-433d-bd41-2eabe5c7448d} [2 channels f32le @ 48000 Hz]
I0702 12:03:38.063185 31304 AvReferenceClock.cpp:149] NTP time offset:799.413ms total offset:799.413ms network duration:8.013ms hostname:pool.ntp.org stratum:3
I0702 12:03:38.063185 31304 AsyncConnections.cpp:552] Timer starts with a timecode of 1530529418862

Thanks,

Adrian


#12

Hi Adrian,

Could you run : genvid-bugreport broadcast with this audio setup and send the zip file that will be generated ? I will compare what this gives to the other one.

You don’t have to worry about the warnings, stamp_scale is used in case we want to stamp the time code onto the video frame, quality is for compressed image quality.

Thanks,

PhM


#13

Hi Adrian,

Is 227E4LH-C a monitor ? What I can see from the logs is that no audio is ever captured, this would explain why no video is sent as there need to be some audio as well.

I checked the Microsoft documentation again and could not find any interesting details on what could trigger an AUDCLNT_E_UNSUPPORTED_FORMAT the way we initialize the audio client.

I am starting to think that this is related to your hardware configuration. Does this problem show up on other PCs ? On the cloud ?

Could you run a dxdiag and send me the results ? I will look if anything could explain that problem.

Thanks,

PhM


#14

227E4LH-C is an external monitor plugged into HDMI port

Sound does work on our cloud instances, so this certainly does look like a hardware specific issue (also means this is not a blocking issue for me, just a minor inconvenience).

Will PM some dxdiag details over.

Thanks,

Adrian


#15

I gave a quick look at the DxDiag output, I could not see any obvious reason why the unsupported format error is returned. I found the same Realtek chip as there is on almost every motherboard, only some configurations are different from mine. I will try to mimic your configuration and run a test to see if I get the error as well.

Thanks,

PhM