Genvid Forum

Genvid Technologies

Problem upgrading a cluster to 1.28.0 from previous version

We have found some problems when a bastion is upgraded from a previous version (like 1.27.1) to 1.28.0.

  1. The first is that, by default, genvid-bastion install will not set the new default providers available in 1.28.0. The new default providers are required in order to work with Terraform 0.14’s new providers specifications. To remedy to this problem, you can load the providers manually using this command from the SDK 1.28.0 installation path:
genvid-bastion set-default-terraform-providers .\bastion-services\terraform\providers\default.json
  1. The second problem is with upgrading the clusters to terraform 0.14. Sometimes, the state of the clusters isn’t updated fast enough and some clusters are skipped. This script ( - 1.7 KB) will refresh the state before applying the changes.

  2. Furthermore, after an upgrade, you may see an error message similar to this:

Could not retrieve the list of available versions for provider hashicorp/aws:
locked provider 3.39.0 does not match
configured version constraint ~> 3.35.0; must use terraform init -upgrade to
allow selection of new versions.

In this case the solution is to run terraform init -upgrade manually on each of your clusters in %USERPROFILE%/.genvid/terraform/workdir/{clustername}/tf folders.

A patch version will be available soon that addresses those problems.