Genvid Forum

Genvid Technologies

Install-toolbox error


#1

I’m trying to install and use the SDK for the first time, and am having various problems on multiple PCs. Currently I started over on a fresh copy of Win10 1809, with SDK 1.18.0.

When running py install-toolbox.py --user I get the error:

Collecting ipgetter (from genvid-toolbox==1.18.0)
  Could not find a version that satisfies the requirement ipgetter (from genvid-toolbox==1.18.0) (from versions: )
No matching distribution found for ipgetter (from genvid-toolbox==1.18.0)

Here’s a screenshot of the command line:


#2

Hi Shuichi,

Welcome to our forum. The issue you have mentioned above has been experienced on our side as well. This is not an issue with the Genvid SDK but rather with the call to ipgetter which is no longer available. We have a fix for this coming in our next release (estimated next week).

In the meantime, there is a workaround solution available so you can continue your work.

Download the attached file and run pip install --user ipgetter-0.7.tar.gz. Once this step is complete, try running the py install-toolbox.py --user command again.

Thank you!
Sophie


Download: ipgetter-0.7.tar.gz


#3

Sophie thank you for the quick response! After a couple more issues, I got the tutorial web sample working.


#4

Hi Sophie,

this used to work for me, but after reinstalling my windows I can’t get it to work anymore:

PS C:\Genvid\Genvid Technologies SDK 1.18.0> pip install --user ipgetter-0.7.tar.gz
Processing c:\genvid\genvid technologies sdk 1.18.0\ipgetter-0.7.tar.gz
Installing collected packages: ipgetter
  Found existing installation: ipgetter 0.7
    Uninstalling ipgetter-0.7:
      Successfully uninstalled ipgetter-0.7
  Running setup.py install for ipgetter ... done
Successfully installed ipgetter-0.7
PS C:\Genvid\Genvid Technologies SDK 1.18.0> py .\install-toolbox.py --user
Processing c:\genvid\genvid technologies sdk 1.18.0\genvid_toolbox-1.18.0-py3-none-any.whl
Requirement already satisfied: psutil in c:\users\moritz\appdata\roaming\python\python35\site-packages (from genvid-toolbox==1.18.0)
Requirement already satisfied: requests in c:\users\moritz\appdata\roaming\python\python35\site-packages (from genvid-toolbox==1.18.0)
Requirement already satisfied: spur in c:\users\moritz\appdata\roaming\python\python35\site-packages (from genvid-toolbox==1.18.0)
Requirement already satisfied: pycryptodomex in c:\users\moritz\appdata\roaming\python\python35\site-packages (from genvid-toolbox==1.18.0)
Requirement already satisfied: boto3 in c:\users\moritz\appdata\roaming\python\python35\site-packages (from genvid-toolbox==1.18.0)
Requirement already satisfied: humanize in c:\users\moritz\appdata\roaming\python\python35\site-packages (from genvid-toolbox==1.18.0)
Requirement already satisfied: hvac in c:\users\moritz\appdata\roaming\python\python35\site-packages (from genvid-toolbox==1.18.0)
Requirement already satisfied: python-nomad in c:\users\moritz\appdata\roaming\python\python35\site-packages (from genvid-toolbox==1.18.0)
Collecting ipgetter (from genvid-toolbox==1.18.0)
  Could not find a version that satisfies the requirement ipgetter (from genvid-toolbox==1.18.0) (from versions: )
No matching distribution found for ipgetter (from genvid-toolbox==1.18.0)
You are using pip version 9.0.1, however version 18.1 is available.
You should consider upgrading via the 'python -m pip install --upgrade pip' command.
Traceback (most recent call last):
  File ".\install-toolbox.py", line 193, in <module>
    exit(main())
  File ".\install-toolbox.py", line 178, in main
    install_toolbox(package=options.package, user=options.user)
  File ".\install-toolbox.py", line 61, in install_toolbox
    install_packages(package, user=user)
  File ".\install-toolbox.py", line 46, in install_packages
    run(cmd, check=True)
  File "C:\Users\moritz\AppData\Local\Programs\Python\Python35\lib\subprocess.py", line 398, in run
    output=stdout, stderr=stderr)
subprocess.CalledProcessError: Command '['C:\\Users\\moritz\\AppData\\Local\\Programs\\Python\\Python35\\python.exe', '-m', 'pip', 'install', '--user', 'C:\\Genvid\\Genvid Technologies SDK 1.18.0\\genvid_toolbox-1.18.0-py3-none-any.whl']' returned non-zero exit status 1

Any ideas what I’m doing wrong? I have tried upgrading to 1.19, but that is not working due to a different issue (which my colleague will be looking into later today)

For the record: I installed 1.19 before trying to install 1.18, but wanted to downgrade to since 1.19 wasn’t working.


#5

Hi Moritz,

It is possible that your pip is pointing to a different version of python than py.

Please try py -3 -m pip install --user ipgetter-0.7.tar.gz

Thanks!
Sophie