Genvid Forum

Genvid Technologies

Cloud Setup Staring Unity Job stays on pending forever, no logs

Currently setting up cloud setup (aws) and we’ve setup all. and the service and the web part is already running, but the unity job never gets to the status of running, its stuck in pending, and there are no logs to check, or did I miss something? maybe If there are logs, I can just debug what went wrong.

any help would be greatly appreciated.

Hi Ramos,

It is likely because the game instance is still provisioning (i.e. not up yet). It can take up to 30 mins for Windows box to provision and register as a Nomad client in the Cluster UI.

You can find more information on this topic in our documentation here:


thanks for pointing that out, totally missed it, now that I look at the output logs on the cluster, it doesn’t contain any public_game_ips. so maybe thats that, so I just destroyed the cluster, cleaned up the instance and ‘plan apply’ it again, and now it has public_game_ips when checking the output log. hopefully it works now after waiting the 30 min cooldown.


I have another issue, i cleared up all my clusters, but its not the genvid sdk is not installing on cloud by using:
genvid-sdk -c clusterId setup
but when i run the server it says that the leafd and other services is not there. should I clean or uninstall the bastion and start fresh?

Hi Ramos,

You shouldn’t need to restart, just run through the steps mentioned here in the sample documentation:

To be safe you could also run a clean-config command before reloading the cluster (replacing $CLUSTER with your cluster name). This will remove all jobs from the Cluster-UI: genvid-sdk -c $CLUSTER clean-config